Задать вопрос
25 декабря, 13:55

Дано четыре целых числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные

Входные данные: с клвиатуры вводится 4 целых числа

Выходные данные: необходимо вывести на экран преобразованные числа в той же последовательности

Пример входных и выходных данных

№ теста Входные данные Выходные данные

1 3 5 - 2 - 4 9 25 16 256

+5
Ответы (1)
  1. 25 декабря, 17:35
    0
    Program n1;

    var a, b, c, d: integer;

    begin

    readln (a, b, c, d) ;

    if a>0 then a:=a*a

    else a:=a*a*a*a;

    if b>0 then b:=b*b

    else b:=b*b*b*b;

    if c>0 then c:=c*c

    else c:=c*c*c*c;

    if d>0 then d:=d*d

    else d:=d*d*d*d;

    writeln (a,' ', b,' ', c,' ', d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четыре целых числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы