Задать вопрос
23 декабря, 12:11

Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны сумме своих делителей, не включая само число, но включаю единицу

+2
Ответы (1)
  1. 23 декабря, 14:51
    0
    Var n, i, s:integer;

    begin

    read (n) ;

    s:=0;

    for i:=1 to n-1 do begin

    if n mod i = 0 then s:=s+i;

    end;

    if s = n then writeln ('sovershennoye') else writeln ('ne sovershennoye') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая вводит число N и определяет является ли число N совершенным. Совершенные числа - это те числа, которые равны ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы