Задать вопрос
20 декабря, 19:37

1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм.

2. напишите прог, в которой осуществляется ввод целых чисел, до тех пор, пока не будет введен 0 и определено максимальное из введенных чисел

+5
Ответы (1)
  1. 20 декабря, 21:17
    0
    Задача 1

    Var i, sum:integer;

    mas:array [1 ... 10] of integer;

    Begin

    for i:=1 to 10 do begin

    mas[i]:=random (20) ;

    write (' ', mas[i]) ;

    sum:=sum+mas[i];

    end;

    writeln;

    write ('Среднее арифметическое этих чисел = ', sum/10) ;

    End.

    Задача 2

    Var i, max:integer;

    Begin

    readln (i) ;

    while (i0) do begin

    if (i>max) then max:=i;

    readln (i) ;

    end;

    Writeln ('Максимальное число: ', max) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм. 2. напишите ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы