Задать вопрос
29 августа, 00:38

Составить программу начисления стипендии группе студентов из 25 человек

по итогам сессии из 5 экзаменов. Стипендия в размере 900 рублей

начисляется студенту, не имеющему троек. Посчитать сумму, необходимую

для выплаты стипендии и вывести список студентов, получающий стипендию.

+1
Ответы (1)
  1. 29 августа, 03:12
    0
    Program Stipendiya;

    type

    Student = record

    Ocenka: array [1 ... 5] of Byte;

    end;

    var

    i, j: Byte;

    Summa: Integer;

    Troechik: Boolean;

    Studenti: array [1 ... 25] of Student;

    begin

    for i:=1 to 25 do

    begin

    / / Zapolnyaem ocenki studentov:

    WriteLn ('Vvedite ocenki '+IntToStr (i) + ' studenta: ') ;

    for j:=1 to 5 do

    begin

    Write ('Ocenka za '+IntToStr (i) + ' ekzamen: ') ;

    ReadLn (Studenti[i]. Ocenka[j]) ;

    end;

    end;

    / / Chitaem summu

    S:=0;

    WriteLn ('') ;

    for i:=1 to 25 do

    begin

    //

    Troechik:=False;

    //

    for j:=1 to 5 do

    if Studenti[i]. Ocenka[j] < 4 then Troechik:=True;

    //

    if not Troechik then

    begin

    WriteLn ('Vidat stipendiu '+IntToStr (i) + ' studentu') ;

    Summa:=Summa + 900;

    end;

    end;

    / / Vivod summi vsex stipendii

    WriteLn ('Summa vsex stipendii = '+IntToStr (Summa)) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу начисления стипендии группе студентов из 25 человек по итогам сессии из 5 экзаменов. Стипендия в размере 900 рублей ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы