Задать вопрос
25 сентября, 08:24

Из n случайных чисел в интервале [10; 200) найти количество и сумму нечетных чисел. Написать программу.

+5
Ответы (1)
  1. 25 сентября, 09:17
    0
    program name;

    var i, n, x, summa, count:integer;

    begin

    Writeln ('Vvedite n: ') ;

    readln (n) ; / / кол во чисел

    summa:=0;

    count:=0;

    Randomize;

    for i:=1 to n do//цикл выполняется n раз

    begin

    x : = random (189) + 10; //получаем слуайное число из интервала

    if (x mod 2 = 1) then//проверяем число на нечетность, если да то считаем

    begin

    summa:=summa+x;

    count:=count+1;

    writeln ('ne chetnoe') ; / / выводи число четное или нет (можно убрать строку)

    end;

    writeln (x) ; / / пишем само число (можно убрать строку)

    end;

    writeln ('Kolvo: ', count,' summa: ', summa) ; / / выводим сумму и количество

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Из n случайных чисел в интервале [10; 200) найти количество и сумму нечетных чисел. Написать программу. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы