Задать вопрос
19 июля, 02:48

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

Программа должна вывести максимальный повторяющийся элемент в массиве или число - 1, если ни один элемент не повторяется.

+2
Ответы (1)
  1. 19 июля, 03:09
    0
    Var

    a:array [1 ... 10000] of integer;

    i, n, a_max, c;

    begin

    read (n) ;

    a_max:=0;

    c:=0;

    for i:=1 to n do

    begin

    a[i] : = random (100) ; / / автозаполнение массива

    print (a[i]) ;

    if a[i]>a_max then a_max:=a[i]; / / поиск максимального элемента

    end;

    writeln;

    for i:=1 to n do

    if a[i]=a_max then inc (c) ; / / поиск повторяющихся элементов

    if c>=2 then write (a_max)

    else write (-1) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы