Задать вопрос
1 марта, 16:53

Написать программу на Pascal

Пользователь вводит число. Сколько последовательно расположенных натуральных чисел необходимо, что бы их произведение стало больше введенного пользователем числа.

+4
Ответы (1)
  1. 1 марта, 18:40
    0
    Var

    a, b, c:integer;

    Begin

    b:=1; c:=1;

    Write ('Введите число: ') ; readln (a) ;

    while (b<=a) do

    begin

    c:=c+1;

    b:=b*c;

    end;

    Writeln ('Ответ: ', c) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Pascal Пользователь вводит число. Сколько последовательно расположенных натуральных чисел необходимо, что бы их ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы