Задать вопрос
6 сентября, 15:48

задача 1

Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел.

задача 2

Составить программу, которая удаляет в строке S все буквы "о"

+1
Ответы (1)
  1. 6 сентября, 17:24
    0
    На всякий случай сделал проверку и на русские, и на английские.

    задача 1.

    uses crt;

    var i:integer;

    s:string;

    begin

    i:=1;

    read (s) ;

    repeat

    if (s[i]='a') or (s[i]='а') then

    s:=copy (s, 1, i) + ' '+copy (s, i+1, length (s)) ;

    i:=i+1;

    until i=length (s) + 1;

    writeln (s) ;

    end.

    задача 2.

    uses crt;

    var i:integer;

    s:string;

    begin

    i:=1;

    read (s) ;

    repeat

    if (s[i]='о') or (s[i]='o') then

    s:=copy (s, 1, i-1) + ' '+copy (s, i+1, length (s)) ;

    i:=i+1;

    until i=length (s) + 1;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «задача 1 Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел. задача 2 Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы