Задать вопрос
8 июня, 09:18

Дается последовательность из N чисел. Выведите результат произведения максимального и минимального элементов последовательности.

Формат входных данных

Первая строка входного файла содержит целое число N (1 < = N < = 100000). В следующей строке задаются N положительных целых чисел, каждое из которых меньше или равно 10^9.

+2
Ответы (1)
  1. 8 июня, 12:56
    0
    Program asd;

    var a:array[1 ... 100000] of integer;

    b, c, i, n, imax, imin:integer;

    f1, f2:text;

    begin

    assign (f1,'input. txt') ;

    assign (f2,'output. txt') ;

    reset (f1) ;

    readln (f1, n) ;

    for i:=1 to n do

    begin

    read (f1, b) ;

    a[i]:=b;

    end;

    imax:=1;

    imin:=1;

    for i:=2 to n do if a[i]>a[imax] then imax:=i;

    for i:=2 to n do if a[i]
    rewrite (f2) ;

    c:=a[imax]*a[imin];

    write (f2, c) ;

    close (f1) ;

    close (f2) ;

    end.

    в папке с прогой надо создать два txt файла input, output.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дается последовательность из N чисел. Выведите результат произведения максимального и минимального элементов последовательности. Формат ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы