Задать вопрос
23 ноября, 12:50

Составить программу вычисления двузначного числа, сумма кубов цифр которого равна n.

+5
Ответы (1)
  1. 23 ноября, 15:38
    0
    Var

    a, b, k:byte;

    n:integer;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    k:=0;

    For a: = 1 to 9 do

    For b: = 0 to 9 do

    if a*a*a+b*b*b = n then

    Begin

    Write (a, b,' ') ;

    k:=k+1

    End;

    if k = 0 then Write ('Таких чисел не существует.')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления двузначного числа, сумма кубов цифр которого равна n. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы