Задать вопрос
8 июня, 18:28

Написать в программе Паскаль:

Пирожок в столовой стоит а рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: а, b, n и должна вывести два числа: стоимость покупки в рублях и копейках

+1
Ответы (2)
  1. 8 июня, 20:49
    0
    A, b, n, s1, s2 : integer;

    begin

    write ('введите стоимость пирожка в рублях ') ;

    readln (a) ;

    write ('введите стоимость пирожка в копейках ') ;

    readln (b) ;

    write ('введите количество пирожков ') ;

    readln (n) ;

    s1:=a*n;

    s2:=b*n;

    writeln ('стоимость покупки в рублях ', s1) ;

    writeln ('стоимость покупки в копейках ', s2) ;

    end.
  2. 8 июня, 22:02
    0
    Program zadanie;

    Var a, b, n:integer;

    Begin

    Writeln ('Введите стоимость пирожка в рублях и копейках') ;

    Readln (a, b) ;

    Writeln ('Сколько нужно купить пирожков') ;

    Readln (n) ;

    Writeln ('Стоимость покупки в рублях=', n*a + ((b*n) div 100)) ;

    Writeln ('Стоимость покупки в копейках=', (n*b) mod 100) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать в программе Паскаль: Пирожок в столовой стоит а рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы