Задать вопрос
28 мая, 20:20

напишите программу, которая вводит с клавиатуры дынные о n лицах (n меньше либо равно 50) и выводит на экран фамилии и имена тех, кто родилсяв день z месяца.

+1
Ответы (1)
  1. 28 мая, 23:13
    0
    type

    person=record

    fam:string;

    imya:string;

    day:integer;

    end;

    var

    a:array[1 ... 50] of person;

    i, n, z:integer;

    begin

    write ('n=') ; readln (n) ;

    for i:=1 to n do

    begin

    write ('fam-') ; readln (a[i]. fam) ;

    write ('imya-') ; readln (a[i]. imya) ;

    write ('day-') ; readln (a[i]. day) ;

    end;

    write ('z-') ; readln (z) ;

    for i:=1 to n do

    if a[i]. day=z then writeln (a[i]. fam, ' ', a[i]. imya) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «напишите программу, которая вводит с клавиатуры дынные о n лицах (n меньше либо равно 50) и выводит на экран фамилии и имена тех, кто ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы