Задать вопрос
10 января, 17:23

Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы:

За цифрой 1 могли следовать только цифры 4, 5, 7, 9, 10

За цифрой 2 - только 5, 6, 8, 10, 11

За цифрой 3 - только 6, 7, 9, 11, 12

За цифрой 4 - только 1, 7, 8, 10, 12

За цифрой 5 - только 1, 2, 8, 9, 11

За цифрой 6 - только 2, 3, 9, 10, 12

За цифрой 7 - только 1, 3, 4, 10, 11

За цифрой 8 - только 2, 4, 5, 11, 12

За цифрой 9 - только 1, 3, 5, 6, 12

За 10 - только 1, 2, 4, 6, 7

За 11 - только 2, 3, 5, 7, 8

За 12 - только 3, 4, 6, 8, 9

Примерные результаты программы:

1473, 21106, 112, 82

+2
Ответы (1)
  1. 10 января, 18:50
    0
    {

    Вам следовало бы более точно описать, что вам нужно.

    Непонятно, что это за условие со следованием. В примере 21106 за цифрой 2 следует 11, но за 11 не следует ничего из перечисленного. Ну или в нем 10 следует за 1, но тогда зачем условия следования для 10 ... 12?

    + ничего не сказано про случайное распределение этих чисел. Так-то программа, которая все время выводит "1", тоже подходит под эти условия

    }

    const

    R: array[1 ... 12,1 ... 5] of integer = (

    (4,5,7,9,10), / / 1

    (5,6,8,10,11), / / 2

    (6,7,9,11,12), / / 3

    (1,7,8,10,12), / / 4

    (1,2,8,9,11), / / 5

    (2,3,9,10,12), / / 6

    (1,3,4,10,11), / / 7

    (2,4,5,11,12), / / 8

    (1,3,5,6,12), / / 9

    (1,2,4,6,7), / / 10

    (2,3,5,7,8), / / 11

    (3,4,6,8,9) / / 12

    ) ;

    var i, k:integer;

    begin

    k : = 1 + random (12) ;

    for i : = 1 to 1 + random (3) do

    begin

    write (k) ;

    k : = R[k, 1 + random (5) ];

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу по выдаче рандомных чисел, содержащих от 1 до 5 знаков, состоящих из чисел от 1 до 12, так чтобы: За цифрой 1 могли ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Составьте алгоритм (PascalABC), в результате которого получится "слово", состоящее из букв "a", "b", "c", "d", "e", "f", "g", "h", "i", "j", "k", "l", стоящих в случайном порядке, при этом: за "a" могут следовать только "e и "i";
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)
3. С помощью каких команд можно запустить программу Excel? a) Пуск - Программы - Microsoft Office - Microsoft Office Excel* b) Пуск - Программы - Каталог Windows c) Пуск - Программы - Стандартные - Блокнот d) Программы - Microsoft Office - Microsoft
Ответы (1)
С помощью каких команд можно запустить программу Excel? a) Пуск - Программы - Microsoft Office - Microsoft Office Excel b) Пуск - Программы - Каталог Windows c) Пуск - Программы - Стандартные - Блокнот d) Программы - Microsoft Office - Microsoft
Ответы (2)