Задать вопрос
9 марта, 09:45

Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая определяет время прибытия самолета в аэропорт назначения в виде "чч: мм" Формат входных данных: С клавиатуры вводится четыре числа через пробел НН, ММ, НР, МР, обозначающие соответственно часы и минуты вылета и часы и минуты продолжительности полета. Формат выходных данных: На экран вывести время прибытия самолета в аэропорт назначения в виде "чч: мм

+3
Ответы (1)
  1. 9 марта, 13:41
    0
    Var

    hh, mm, hp, mp: integer;

    begin

    readln (hh, mm, hp, mp) ;

    hh : = hp * 60 + hh * 60 + mm + mp;

    writeln (hh div 60 mod 24, ':', hh mod 60) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Известно время вылета самолета: НН часов и ММ минут, а также продолжительность полета (НР часов и МР минут). Напишите программу, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы