Задать вопрос
6 августа, 23:11

Дан массив, состоящий из целых чисел (до 10000) Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с одинаковыми знаками.

+1
Ответы (1)
  1. 6 августа, 23:34
    0
    Const

    n = 20;

    var

    a: array[1 ... n] of integer;

    i: integer;

    flag: boolean;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (19999) - 9999;

    Write (a[i]:6) ;

    end;

    Writeln;

    i : = 1;

    flag : = False;

    repeat

    flag : = (sign (a[i]) = sign (a[i + 1])) ;

    i : = i + 1

    until flag or (i > n) ;

    if flag then Writeln ('Есть пара соседних элементов с одним знаком')

    else Writeln ('Нет пар соседних элементов с одним знаком')

    end.

    Тестовое решение:

    Элементы массива

    2440 - 2414 - 3192 - 6912 - 8537 7364 2869 - 2505 8875 2662 401 7398 2213 8804 2039 1485 4213 8359 - 2410 - 5844

    Есть пара соседних элементов с одним знаком
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив, состоящий из целых чисел (до 10000) Напишите программу, которая определяет, есть ли в массиве пара соседних элементов с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы