Задать вопрос
3 ноября, 18:36

Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке программирования)

+5
Ответы (1)
  1. 3 ноября, 18:47
    0
    var a, b, c:integer;

    begin

    for a: = 1 to 20 do

    for b: = 1 to 20 do

    for c: = 1 to 20 do

    begin

    if a*a+b*b=c*c then

    writeln (a:4, b:4, c:4) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы