Задать вопрос
20 сентября, 05:02

Помогите с задачей!

напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и воскресениям. Вычисление стоимости разговора по телефону. Введите исходные данные: Длительность разговора (целое количество минут) - 3 День недели (1-понедельник, ... 7-воскресенье) - - 5 Предоставляется скидка 20% Стоимость разговора: 5.52 руб. (она большая должна быть и для паскаля) !

+4
Ответы (1)
  1. 20 сентября, 08:30
    0
    Program D1KPxx3;

    uses crt;

    var

    i:integer;

    min, rez:real;

    b:char;

    label 1,2;

    begin

    1:write ('Введите время разговора') ;

    read (min) ;

    writeln ('Введите номер дня недели') ;

    read (i) ;

    if (i=6) or (i=7) then

    begin

    rez: = ((min*5.52) - (min*0.2)) ;

    write ('Стоимость разговора с учетом скидки равна: ', rez) ;

    goto 2;

    end

    else

    rez:=min*5.52;

    write ('Стоимость разговора равна: ', rez) ;

    2:writeln ('Ещё? Y/N') ;

    readln (b) ;

    if b='Y' then

    goto 1;

    if b='N' then

    write ('Пока!') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с задачей! напишите программу определения стоимости разговора по телефону с учётом скидки 20% представляемой по субботам и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы