Задать вопрос
5 августа, 19:20

Вводятся целые числа A и B. Выведите среднее арифметическое всех неотрицательных чисел от A до B

Нужно составить программу в паскале.

+5
Ответы (1)
  1. 5 августа, 20:32
    0
    1 способ

    var

    a, b: integer;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    var x : = Range (a, b) ;

    writeln ('Последовательность: ') ;

    x. Println;

    writeln ('Ср. ариф. неотриц чисел: ') ;

    writeln (x. Where (x - > x > = 0). Average) ;

    end.

    2 способ

    var a, b, i, s: integer; k: real;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    writeln ('Последовательность: ') ;

    for i:=a to b do write (i,' ') ;

    writeln () ;

    s:=0;

    for i:=a to b do

    if i>=0 then begin

    s:=s+i;

    k:=k+1;

    end;

    writeln ('Ср. ариф. неотриц чисел: ') ;

    write (s/k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Вводятся целые числа A и B. Выведите среднее арифметическое всех неотрицательных чисел от A до B Нужно составить программу в паскале. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы