Задать вопрос
16 сентября, 20:53

Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную.

+4
Ответы (1)
  1. 16 сентября, 23:55
    0
    Program todec;

    uses crt;

    function detob (x:integer) : string;

    var s:string;

    begin

    s:='';

    while x>0 do

    begin

    s:=chr (ord ('0') + x mod 2) + s;

    x:=x div 2;

    end;

    detob:=s;

    end;

    var a: integer;

    begin

    clrscr;

    writeln ('Введите число:') ;

    readln (a) ;

    writeln ('Полученное число:', detob (a)) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу по информатике (на паскале) на перевод из десятичной системы счисления в двоичную. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы