Задать вопрос
1 декабря, 16:36

Решить не могу задачи по информатике:

1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями.

2. Составьте программу, которая заполняет массив h [1 ... 10] случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями.

3. Составьте программу, которая заполняет массив h [1 ... 10] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечётными значениями и количество элементов с нечётными значениями.

5. Составьте программу, которая заполняет массив h [1 ... 20] случайными целыми числами в диапазоне от 1 до 20 и находит среднее арифметическое элементов кратных трём и чётными индексами.

+1
Ответы (1)
  1. 1 декабря, 20:05
    0
    1) var h:array[1 ... 8]of integer;

    i:integer;

    begin

    write ('massiv') ;

    for i:=1 to 8 do

    read (h[i]) ;

    writeln;

    write ('elementi s otric znach') ;

    for i:=1 to 8 do

    if h[i]<0 then write (h[i],' ') ;

    end.

    2) var h:array[1 ... 10]of integer;

    i, k:integer;

    begin

    write ('massiv:') ;

    for i:=1 to 10 do

    begin

    h[i]:=random (21) - 10;

    write (h[i],' ') ;

    end;

    writeln;

    for i:=1 to 10 do

    if h[i]<0 then k:=k+1;

    write ('kol-vo elem s otric znach:', k) ;

    end.

    3) var h:array[1 ... 10]of integer;

    i, k, p:integer;

    begin

    write ('massiv:') ;

    for i:=1 to 10 do

    begin

    h[i]:=random (10) + 1;

    write (h[i],' ') ;

    end;

    writeln;

    p:=1;

    for i:=1 to 10 do

    if h[i] mod 2=1 then

    begin

    k:=k+1;

    p:=p*h[i];

    end;

    write ('kol-vo elem s nechet znach:', k,' proizvedenie:', p) ;

    end.

    5) var h:array[1 ... 20]of integer;

    i, k, s:integer;

    a:real;

    begin

    write ('massiv:') ;

    for i:=1 to 10 do

    begin

    h[i]:=random (20) + 1;

    write (h[i],' ') ;

    end;

    writeln;

    for i:=1 to 10 do

    if (h[i] mod 3=0) and (i mod 2=0) then

    begin

    k:=k+1;

    s:=s+h[i];

    end;

    a:=s/k;

    write ('srednee arifmet:', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы