Задать вопрос
18 февраля, 17:32

Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое

+2
Ответы (2)
  1. 18 февраля, 17:40
    0
    program random_1;

    var

    x, sum, i:integer;

    begin

    randomize;

    writeln ('Ряд случайных чисел: ') ;

    for i:=1 to 10 do begin

    x:=random (20) + 1;

    sum:=sum+x;

    if i10 then write (x,', ')

    else writeln (x,'.') ;

    end;

    writeln ('Среднее арифметическое этих чисел ', sum/10) ;

    end.
  2. 18 февраля, 19:31
    0
    const

    n = 10;

    var

    a, summ, i:integer;

    begin

    randomize;

    summ : = 0;

    for i : = 1 to n do

    begin

    a : = random (20) + 1;

    summ : = summ + a;

    write (a, ' ') ;

    end;

    writeln;

    writeln ('Среднее арифметическое этих чисел ', summ / n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы