Задать вопрос
14 января, 16:15

Написать программу, считающую сумму цифр целого числа. программа должна быть написана в TP (Turbo Pascal)

+2
Ответы (1)
  1. 14 января, 17:48
    0
    program z1;

    var S, n:integer;

    begin

    writeln ('Введите число') ;

    readln (n) ;

    while n>0 do begin

    S:=S+n mod 10;

    n:=n div 10;

    end;

    writeln ('S=', S) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, считающую сумму цифр целого числа. программа должна быть написана в TP (Turbo Pascal) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы