Задать вопрос
10 марта, 18:27

Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом работы программы является последовательность чисел заканчивающихся (по гипотезе Сиракуза) единицей.

+4
Ответы (1)
  1. 10 марта, 21:05
    0
    Var

    a, b, n, i: integer;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    n : = i;

    write (n) ;

    while n 1 do

    begin

    if (n mod 2) = 0 then

    n : = n div 2

    else

    n : = (3 * n + 1) div 2;

    write (' - > ', n) ;

    end;

    writeln;

    end;

    end.

    чесно передрано с некого сайта и доработано под задачу
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу проверяющую гипотезу Сиракуза для всех чисел от N до M. Значения N и M вводятся пользователем с клавиатуры. Результатом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы