Задать вопрос
8 февраля, 00:41

Составьте программу в Паскале для поиска:

a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры

b) произведения отрицательных элементов массива а от 1 до 100

c) количества нулевых элементов массива с сотней элементов

+3
Ответы (1)
  1. 8 февраля, 02:04
    0
    А) uses crt;

    const n=10;

    var a:array[1 ... n] of integer;

    i, sum:integer;

    begin

    for i:=1 to n do

    begin

    a[i]:=random (100) - 50;

    write (a[i]:4) ;

    if a[i]>0 then sum:=sum+a[i];

    end;

    writeln;

    writeln ('Сумма положительных элементов = ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу в Паскале для поиска: a) суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы