Задать вопрос
1 июня, 15:25

1. Cоставить программу вычисления площади круга: S = п (пи) * R^2

2. Cоставить программу вычисления площади треугольника: S=1/2*A*H

1) Выделить целую часть результата.

2) Выделить дробную часть результата

3) Округлить результат

4) Округлить до целого, не превосходящего рельтат

3. Составить программу вычисления выражения: Y=Sin (a+b/2)

при a=15, b=30 (градусов)

+3
Ответы (1)
  1. 1 июня, 16:40
    0
    Const n=3.1415;

    var a, h, S, Rez: real;

    begin

    ReadLn (a) ;

    ReadLn (h) ;

    S:=a*h/2;

    Rez:=trunc (S) ; {отбрасываем дробную часть}

    WriteLn (Rez) ;

    Rez:=round (S) ; {выделяем целую часть}

    WriteLn (Rez) ;

    Rez:=frac (S) ; {выделяем дробную часть}

    WriteLn (Rez) ;

    ReadLn;

    end.

    {Вопрос: в третьем задании до какой точности округлять? }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы