Задать вопрос
25 декабря, 03:50

Дан массив a из n

целых чисел. Требуется вывести только неотрицательные числа.

Формат входных данных

На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.

На следующей строке через пробел записаны целые числа ai

(∣∣ai∣∣≤103)

- элементы массива.

Формат выходных данных

Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

+3
Ответы (1)
  1. 25 декабря, 06:36
    0
    Var

    i, n: integer;

    a: array[1 ... 1000]of integer;

    begin

    readln (n) ;

    for i : = 1 to n do read (a[i]) ;

    writeln;

    for i : = 1 to n do if (a[i] > = 0) then write (a[i], ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы