Задать вопрос
7 сентября, 03:51

С клавиатуры вводится n целых чисел, несколько положительный и несколько отрицательных, найти сумму положительных. (паскаль) Помогите написать программу.

+1
Ответы (1)
  1. 7 сентября, 05:42
    0
    Var i, n, a, sum:integer;

    begin

    readln (n) ;

    sum:=0;

    for i:=1 to n do

    begin

    readln (a) ;

    if a>0 then

    sum:=sum+a

    end;

    writeln (sum)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводится n целых чисел, несколько положительный и несколько отрицательных, найти сумму положительных. (паскаль) Помогите ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы