Задать вопрос
9 января, 17:54

Программа в Pascal

1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м.

2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о

+4
Ответы (1)
  1. 9 января, 20:18
    0
    1. Program prog;

    uses crt;

    var s: string;

    k, i: integer;

    begin;

    write ('S = ') ;

    readln (s) ;

    for i:=1 to length (s) do

    if (s[i]='м') or (s[i]='М') then k:=k+1;

    writeln (k) ;

    end.

    2. Program prog;

    uses crt;

    var

    s, n:string;

    i:integer;

    begin

    write ('S = ') ;

    readln (s) ;

    n:='';

    for i:=1 to length (s) do

    if (s[i]'о') and (s[i]'О') then

    n:=n+s[i];

    s:=n;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы