Задать вопрос
22 ноября, 04:05

Дано натуральное число. Установить является ли последовательность его цифр при просмотре их слева направо упорядоченной по неубыванию. Например, для чисел 5321 и 9663 ответ положительный, для чисел 7820 и 9663 отрицательный и т. п.

Написать программу на паскале, не используя массивы, boolean

+5
Ответы (1)
  1. 22 ноября, 07:30
    0
    Var s: string;

    begin

    write ('число: ') ; readln (s) ;

    if s=s. Sorted. Reverse. JoinIntoString ('') then

    writeln ('упорядочено по неубыванию')

    else writeln ('НЕ упорядочено') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число. Установить является ли последовательность его цифр при просмотре их слева направо упорядоченной по неубыванию. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы