Задать вопрос
12 июня, 21:08

Пусть элементами круга

являются радиус (первый элемент), диаметр (второй элемент) и длина окружности

(третий элемент). Составить программу, которая по номеру элемента запрашивала

бы его соответствующее значение и вычисляла бы площадь круга.

Решение на паскале!

+3
Ответы (1)
  1. 12 июня, 23:18
    0
    var

    a: real;

    k: byte;

    begin

    writeln ('1 - l okp.') ;

    writeln ('2 - r okp.') ;

    writeln ('3 - d okp.') ;

    readln (k) ;

    readln (a) ;

    write ('S = ') ;

    case k of

    1: writeln (sqr (a) / (4 * Pi) : 0:2) ;

    2: writeln (Pi * sqr (a) : 0:2) ;

    3: writeln (Pi * sqr (a / 2) : 0:2) ;

    else writeln ('?') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Пусть элементами круга являются радиус (первый элемент), диаметр (второй элемент) и длина окружности (третий элемент). Составить программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы