Задать вопрос
23 августа, 16:14

Написать программу для отыскания

max (min (a, b), min (c, d)), не

используя сложные логические условия и вложенные ветвления. Числа a, b, c, d

- целые. Протестировать программу для следующих исходных данных:

а) a=4 b=5 c=6 d=9

б) a=2 b=1 c=6 d=9

в) a=2 b=1 c=8 d=4

г) a=12 b=1 c=6 d=9

+2
Ответы (1)
  1. 23 августа, 18:28
    0
    Var a, b, c, d, m1, m2, max:integer;

    begin

    write ('Введите a, b, c, d: ') ;

    readln (a, b, c, d) ;

    if a
    if c
    if m1
    writeln ('MAX=', max)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для отыскания max (min (a, b), min (c, d)), не используя сложные логические условия и вложенные ветвления. Числа a, b, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы