Задать вопрос
13 ноября, 21:05

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)

+3
Ответы (2)
  1. 13 ноября, 22:27
    0
    Var

    a, b, c, d: integer;

    function max (i1, i2: integer) : integer;

    begin

    if i1 > i2 then max : = i1 else max : = i2;

    end;

    begin

    read (a, b, c, d) ;

    writeln (max (max (max (a, b), c), d)) ;

    end.

    не помню как процедуры писать, но с функциями даже удобнее
  2. 13 ноября, 23:57
    0
    Program ufhg;

    uses crt;

    var a, b, c, d, m: integer;

    begin

    readln (a, b, c, d) ;

    m:=a;

    if (b>m) then m:=b;

    if (c>m) then m:=c;

    if (d>m) then m:=d;

    writeln (m) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы