Задать вопрос
1 июля, 05:47

Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале, используя простые формулы.

+2
Ответы (1)
  1. 1 июля, 07:36
    0
    Var a:string[20]; st, b, i:integer;

    begin

    writeln ('Введите двоичное число:') ;

    readln (a) ;

    st:=1; b:=0;

    for i:=length (a) downto 1 do

    begin

    if a[i]='1' then b:=b+st;

    st:=2*st;

    end;

    writeln (b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу перевода чисел из двоичной системы счисления в десятичную на паскале, используя простые формулы. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы