Задать вопрос
12 марта, 23:12

Дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр

+1
Ответы (1)
  1. 13 марта, 00:45
    0
    Var

    digits: set of '0' ... '9';

    s: string;

    i, p, d, err: integer;

    begin

    digits : = ['0' ... '9'];

    Write ('Введите строку: ') ; Readln (s) ;

    p : = 0;

    for i : = 1 to Length (s) do

    if (s[i] in digits) then

    begin Val (s[i], d, err) ; p : = p + d end;

    Writeln ('Сумма цифр равна ', p)

    end.

    Тестовое решение:

    Введите строку: Сегодня 17 декабря 2014 г. Находим сумму 7 цифр их этой строки.

    Сумма цифр равна 22
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана строка. среди символов встречаются цифры. написать программу, вычисляющую сумму всех цифр ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы