Задать вопрос
4 мая, 08:15

В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи.

Фибон а ччи ч и сла, элементы числовой возвратной последовательности 1, 1, 2, 3, 5, 8, ... (ряда Фибоначчи), в которых каждый последующий член равен сумме двух предыдущих.

+2
Ответы (1)
  1. 4 мая, 10:44
    0
    Program Fibonacci;

    Uses Crt;

    var i, n:integer;

    {Итерационный метод вычисления чисел Фибоначчи}

    function fib_it (n:integer) : integer;

    var a, b, c, i:integer;

    begin

    a:=1; b:=1;

    if (n=1) or (n=2) then fib_it:=1

    else begin

    for i:=3 to n do

    begin

    c:=a+b;

    a:=b;

    b:=c;

    end;

    fib_it:=c;

    end;

    end;

    {main program}

    begin

    clrscr;

    write ('Введите n: ') ;

    readln (n) ;

    for i:=1 to n do write (fib_it (i),' ') ;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В программе паскаль составить программу, выводящую на экран ряд чисел Фибоначчи. Фибон а ччи ч и сла, элементы числовой возвратной ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы