Задать вопрос
27 мая, 21:21

Написать программу, которая находит и выводит на печать все четырёхзначные числа abcd, для которых выполняется : a, b, c, d - разные цифры ab-cd=a+b+c+d

+2
Ответы (1)
  1. 28 мая, 00:16
    0
    {Задачу можно решать несколькими способами. Одним из возможных способов является перебор всех четырехзначных чисел и проверка для каждого из них выполнения условий. Попробуем сократить перебор, для этого преобразуем второе условие:

    10 а+b - (10c+d) = a+b+c+d;

    9 (a-c) = 2 (c+d) ;

    (a-c) / (c+d) = 2/9

    Проанализировав первое условие, получаем, что а=с+2, d=9-c, следовательно 0<=c<=7.}

    program prim4;

    uses crt;

    var a, b, c, d: integer;

    begin

    clrscr;

    for c:=0 to 7 do

    begin

    a:=c+2; d; =9-c;

    for b:=0 to 9 do

    begin

    if (bc) and (ba) and (bd)

    then

    write (a, b, c, d) ;

    writeln

    end;

    end;

    readln;

    end.

    {Таким образом, мы решили задачу, значительно сократив перебор. }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая находит и выводит на печать все четырёхзначные числа abcd, для которых выполняется : a, b, c, d - разные цифры ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы