Задать вопрос
30 сентября, 05:56

1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел.

2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.

+3
Ответы (1)
  1. 30 сентября, 08:31
    0
    1)

    program average;

    var

    i: integer;

    answer, S, tmp: real;

    begin

    for i : = 1 to 5 do

    begin

    readln (tmp) ;

    S : = S + tmp

    end;

    answer : = S / 5;

    writeln (answer)

    end.

    2)

    program equation;

    var

    A, B, C, D, x1, x2: real;

    begin

    writeln ('ввеедите коэфициенты квадратного многочлена') ;

    readln (A) ;

    readln (B) ;

    readln (C) ;

    if A 0 then

    begin

    D : = B*B - 4*A*C;

    if D < 0 then

    writeln ('действительных корней нет')

    else if D = 0 then

    begin

    x1 : = - B / (2*A) ;

    writeln ('Единственный корень: ', x1)

    end else

    begin

    x1 : = (-B + sqrt (D)) / (2*a) ;

    x2 : = (-B - sqrt (D)) / (2*a) ;

    writeln ('Два корня: ', x1,', ', x2)

    end;

    end

    else writeln ('старший коэфициент не может равняться 0')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы