Задать вопрос
3 декабря, 23:10

Слон

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]

По заданным координатам слона и пешки определить, находится ли пешка под боем слона.

Входные данные:

Во входном потоке в первой строке через пробел заданы четыре целых числа (0 < A, B, C, D < 9). Первые пара чисел определяет координаты слона, вторая - координаты пешки.

Выходные данные:

Вывести YES или NO

Пример входного файла (input. txt) :

1 1 2 2

Пример выходного файла (output. txt) :

YES

+1
Ответы (1)
  1. 4 декабря, 00:47
    0
    Var

    A, B, C, D: integer;

    f1, f2: Text;

    begin

    Assign (f1, 'input. txt') ;

    Reset (f1) ;

    Assign (f2, 'output. txt') ;

    Rewrite (f2) ;

    while not Eof (f1) do

    begin

    Readln (f1, A, B, C, D) ;

    if Abs (A - C) = Abs (B - D) then writeln (f2,'YES')

    else writeln (f2,'NO')

    end;

    Close (f1) ;

    Close (f2)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Слон Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%] По заданным координатам слона и пешки определить, находится ли пешка под ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%] Задана продолжительность некоторого события в секундах целым числом. Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Решать в Pascal Найти наибольший элемент заданной целочисленной числовой последовательности. Входные данные: Во входном потоке в первой строке задано натуральное число N (N < = 1000) - количество элементов числовой последовательности.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)