Задать вопрос
17 августа, 07:07

Напишите программу, которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36.

+4
Ответы (1)
  1. 17 августа, 07:26
    0
    Var i, k, j, n, ost, p:integer;

    x, s:string;

    begin

    read (s) ;

    n:=strtoint (s) ;

    for j:=11 to 36 do

    begin

    x:='';

    p:=n;

    k:=0;

    while p0 do

    begin

    ost:=p - (p div j) * j;

    p:=p div j;

    k:=k+1;

    if (ost >9) and (ost <=36) then

    x:=chr (ost+55) + x

    else

    x:=inttostr (ost) + x;

    end;;

    writeln (x,' ', j,' ss') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы