Задать вопрос
9 апреля, 05:55

Напишите программу алгоритмическим языком для нахождения НОД по Евклиду (делить большое число на меньшее, а потом ему присваивать значение остатка)

+4
Ответы (1)
  1. 9 апреля, 09:53
    0
    Var a, b:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    while (a0) and (b0) do

    if a>b then a:=a mod b else b:=b mod a;

    writeln ('НОД=', a+b) ;

    end.

    Пример:

    a=125

    b=50

    НОД=25
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу алгоритмическим языком для нахождения НОД по Евклиду (делить большое число на меньшее, а потом ему присваивать значение ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы