Задать вопрос
14 января, 18:07

Помогите написать программу на паскале)

сортировка Пузырьком

+4
Ответы (1)
  1. 14 января, 18:43
    0
    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, j:integer;

    Begin

    {Заполнение массива}

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ')

    End;

    WriteLn;

    {Сортировка пузырьком}

    For i: = 1 to K do

    For j: = 1 to K-1 do

    if A[j]>A[j+1] then Swap (A[j], A[j+1]) ;

    {Вывод массива}

    Write ('Отсортированный массив: ') ;

    For i: = 1 to K do

    Write (A[i],' ')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале) сортировка Пузырьком ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы