Задать вопрос
16 декабря, 02:00

Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое

в Pascal

+5
Ответы (1)
  1. 16 декабря, 05:13
    0
    Program Lemonly;

    const

    n=10;

    var

    table: array [1 ... n] of real;

    i: integer;

    sum, arifm: real;

    begin

    randomize;

    sum:=0;

    writeln ('Введите ', n, ' чисел:') ;

    for i: = 1 to n do

    begin

    readln (table[i]) ;

    sum:=sum+table[i];

    end;

    writeln () ;

    arifm:=sum/n;

    writeln ('Cреднее арифметическое введённых чисел равно ', arifm:8:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая вводила бы с клавиатуры 10 вещественных чисел и вычисляла бы их среднее арифметическое в Pascal ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы