Задать вопрос
25 августа, 23:32

А) Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б) Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

+2
Ответы (1)
  1. 26 августа, 01:02
    0
    А)

    var

    a:array[1 ... 10]of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    a[i]:=random (20) + 1;

    for i:=10 downto 1 do

    write (a[i],' ') ;

    end.

    б)

    var

    a:array[1 ... 20]of integer;

    i:integer;

    begin

    for i:=1 to 20 do

    a[i]:=random (11*i) + 10*i;

    for i:=1 to 20 do

    if i mod 2=1 then write (a[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «А) Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы