Задать вопрос
2 ноября, 23:16

Составьте программу для Pascal abc, решающую следующую задачу. У продавца имеются гири весом 1, 2, 5 кг. Наберите минимальное кол-во гирь для взвешивания N кг.

+2
Ответы (1)
  1. 3 ноября, 00:25
    0
    Program z1;

    var n:integer;

    s1, s2, s5:integer;

    begin

    write ('n=') ; readln (n) ;

    s5:=n div 5; n:=n mod 5;

    s2:=n div 2; s1:=n mod 2;

    writeln ('5 kg-', s5,'; 2 kg-', s2,'; 1 kg-', s1) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу для Pascal abc, решающую следующую задачу. У продавца имеются гири весом 1, 2, 5 кг. Наберите минимальное кол-во гирь ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы