Задать вопрос
17 апреля, 05:56

1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел.

2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры.

3. Написать программу вычисления положительных чисел. Записать варианты программы с разными видов циклов.

+4
Ответы (1)
  1. 17 апреля, 09:05
    0
    Первая:

    Uses crt;

    Var arr:array[1 ... 100] of integer;

    n, a, c:integer;

    Begin

    Write ('Сколько чисел вы хотите ввести?-') ;

    Readln (n) ;

    for a:=1 to n do

    begin

    Write ('Введите ', a,' число:') ;

    Readln (arr[a]) ;

    end; c:=0;

    For a:=1 to n do

    Begin

    if (arr[a] mod 20) and (arr[a]<0) then c:=c+1;

    end;

    Writeln ('В последовательности ', c,' нечетных отрицательных чисел.') ;

    end.

    Вторая:

    Uses crt;

    Var arr:array[1 ... 100] of integer;

    a, b, c, m:integer;

    begin

    Write ('Сколько чисел вы хотите ввести?-') ;

    Readln (b) ;

    For a:=1 to b do

    begin

    Write ('Введите ', a, ' число:') ;

    Readln (arr[a]) ;

    end;

    For a:=1 to b do

    Begin

    m:=arr[a];

    For c:=1 to 2 do

    begin

    arr[a]:=m*arr[a];

    end; end;

    For a:=1 to b do

    begin

    Writeln ('Куб ', a,' введенного вами числа равен:', arr[a]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы