Задать вопрос
18 марта, 03:58

4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается заданный остаток r или s. 5. Напшите программу, при выполнение которой выводится 1, если заданное число х принадлежит отрезку (a; b), или 0 в противном случае

+5
Ответы (1)
  1. 18 марта, 07:21
    0
    1.

    var a, b, r, s:integer;

    begin

    write ('Введите числа a и b: ') ;

    readln (a, b) ;

    write ('Введите остатки r и s: ') ;

    readln (r, s) ;

    if (a mod b=r) or (a mod b=s) then writeln ('Да, верно')

    else writeln ('Нет, неверно')

    end.

    2.

    var a, b, x:real;

    begin

    write ('Введите числа a и b: ') ;

    readln (a, b) ;

    write ('Введите x: ') ;

    readln (x) ;

    if (a<=x) and (x<=b) then writeln (1)

    else writeln (0)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «4. Напишите программу, определяющую, верно ли, что при деление целого отрицательного числа а на целое положительное число b получается ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы