Задать вопрос
29 мая, 23:53

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Напишите программу, которая находит и выводит номер третьего положительного элемента массива (если из массива вычеркнуть все неположительные элементы, этот элемент стоял бы в получившемся массиве на третьем месте). Если в массиве меньше, чем три положительных элемента, вывести сообщение об этом.

+5
Ответы (1)
  1. 30 мая, 02:43
    0
    const n=30;

    var k:array[1 ... n] of integer; i, t, p:integer;

    begin

    randomize;

    for i:=1 to n do begin

    k[i]:=random (100) ;

    if (k[i]>0) then p:=p+1;

    if (i=3) and (k[3]>0) then t:=k[3];

    end;

    if (p<3) then write ('В массиве меньше трех положительных элементов') else writeln ('Третий элемент массива равен ', t) ;

    end.

    Отрицательного значения в массиве не будет, напиши формулу к массиву k[i]:=твоя формула. Формула должна быть такой, чтобы попадались и отрицательные элементы, а так, программа рабочая
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Напишите программу, которая находит ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы