Задать вопрос
5 декабря, 12:03

Нужно заполнить массив из 10 элементов случайными числами в интервале [-10 ... 10] и найти в нем 2 максимальных элемента и их номера. написать программу на языке паскаль

+2
Ответы (1)
  1. 5 декабря, 13:58
    0
    Const

    n=10; var

    a:array[1 ... n]of integer;

    i, max1, max2, im1, im2:integer;

    begin for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i]:4) ;

    end;

    max1:=a[1]; im1:=1;

    for i:=1 to n do

    if a[i]>max1 then

    begin

    max1:=a[i];

    im1:=i;

    end;

    for i:=1 to n do

    if (a[i]<>max2) then

    begin

    max2:=a[i];

    im2:=i;

    end;

    writeln;

    writeln ('i: ', im1,' max1: ', max1,' i: ', im2,' max2: ', max2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно заполнить массив из 10 элементов случайными числами в интервале [-10 ... 10] и найти в нем 2 максимальных элемента и их номера. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы