Задать вопрос
30 октября, 15:17

Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от знака решотка дважды. Вывести на экран, полученную новую строку.

+3
Ответы (1)
  1. 30 октября, 16:56
    0
    var a:string;

    i, j:integer;

    begin

    readln (a) ;

    while pos ('#', a) 0 do delete (a, pos ('#', a),1) ;

    for i:=1 to length (a) do

    for j:=1 to 2 do

    write (a[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в Pascal ABC, которая из заданной строки получала бы новую строку, удалив все "#" и повторив каждый символ, отличный от ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы