Задать вопрос
26 февраля, 13:06

Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и:

1) отрицательные числа заменяет наих модули, а неотрицательные возводит в квадрат

2) четные числа заменяет на 2, а от нечетных - отнимает 5

3) числа, кратные 6 уменьшает в 2 раза, а у остальных элементов находит целое от деления на 5

4) меняет местами значения третьего и 11 элементов

На экран вывести исходный и преобразованный массив с поясняющим текстом

+4
Ответы (1)
  1. 26 февраля, 15:04
    0
    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:4) ; end;

    writeln;

    for i:=1 to 15 do if a[i]>=0 then a[i]:=sqr (a[i]) else a[i]:=abs (a[i]) ;

    for i:=1 to 15 do write (a[i]:4) ;

    end.

    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    for i:=1 to 15 do if a[i] mod 2=0 then a[i]:=2 else a[i]:=a[i]-5;

    for i:=1 to 15 do write (a[i]:3) ;

    end.

    var a:array[1 ... 15]of integer;

    i:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    for i:=1 to 15 do if a[i] mod 6=0 then a[i]:=a[i] div 2 else a[i]:=a[i] div 5;

    for i:=1 to 15 do write (a[i]:3) ;

    end.

    var a:array[1 ... 15]of integer;

    i, k:integer;

    begin

    for i:=1 to 15 do begin a[i]:=random (31) - 15; write (a[i]:3) ; end;

    writeln;

    k:=a[3];

    a[3]:=a[11];

    a[11]:=k;

    for i:=1 to 15 do write (a[i]:3) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая формирует массив из 15 случайных чисел вдиапазоне от 15 до - 15 и: 1) отрицательные числа заменяет наих ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы